#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\?(?=\S)(?:(?R)|[^?])*\?(?=\s)"
Local $sString = "hello ?color ?size 22 red ?name Yuri ? ? ? " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hello ?name Yuri ? welcome to ?forum Python ? It's awesome!" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hello ?color red ?name Yuri ? ? to the forum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")