using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?(?=\S)(?:(?R)|[^?])*\?(?=\s)";
string input = @"hello ?color ?size 22 red ?name Yuri ? ? ?
hello ?name Yuri ? welcome to ?forum Python ? It's awesome!
hello ?color red ?name Yuri ? ? to the forum";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}