use strict;
my $str = 'hello ?color ?size 22 red ?name Yuri ? ? ?
hello ?name Yuri ? welcome to ?forum Python ? It\'s awesome!
hello ?color red ?name Yuri ? ? to the forum';
my $regex = qr/\?(?=\S)(?:(?R)|[^?])*\?(?=\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}