import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\?(?=\\S)(?:(?R)|[^?])*\\?(?=\\s)";
final String string = "hello ?color ?size 22 red ?name Yuri ? ? ? \n\n\n"
+ "hello ?name Yuri ? welcome to ?forum Python ? It's awesome!\n\n\n"
+ "hello ?color red ?name Yuri ? ? to the forum";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}