$re = '/\?(?=\S)(?:(?R)|[^?])*\?(?=\s)/m';
$str = 'hello ?color ?size 22 red ?name Yuri ? ? ?
hello ?name Yuri ? welcome to ?forum Python ? It\'s awesome!
hello ?color red ?name Yuri ? ? to the forum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);