const regex = /\[(["'])(.*?)\1]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(["\'])(.*?)\\1]', 'gm')
const str = `['Mamie Smith']
["Screamin' Jay Hawkins"]`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);