$re = '/\[(["\'])(.*?)\1]/m';
$str = '[\'Mamie Smith\']
["Screamin\' Jay Hawkins"]';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;