re = /\[(["'])(.*?)\1]/m
str = '[\'Mamie Smith\']
["Screamin\' Jay Hawkins"]'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result