import re
regex = re.compile(r"\[([\"'])(.*?)\1]", flags=re.MULTILINE)
test_str = ("['Mamie Smith']\n"
"[\"Screamin' Jay Hawkins\"]")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)