const regex = /height:\s*(\d+)px/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('height:\\s*(\\d+)px', '')
const str = `.hello-world-chat-size {height: 350px !important;}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}