$re = '/height:\s*(\d+)px/';
$str = '.hello-world-chat-size {height: 350px !important;}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);