using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\s\n])\d{3}[./]\d{3,6}(?:/\d{3})?(?![^\s\n])";
string input = @"Codes like 123/456
123/3456
123/23456
etc are correct
lorem\123/456 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}