re = /(?<![^\s\n])\d{3}[.\/]\d{3,6}(?:\/\d{3})?(?![^\s\n])/m
str = 'Codes like 123/456
123/3456
123/23456
etc are correct
lorem\\123/456 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end