$re = '/(?<![^\s\n])\d{3}[./]\d{3,6}(?:/\d{3})?(?![^\s\n])/m';
$str = 'Codes like 123/456
123/3456
123/23456
etc are correct
lorem\\123/456 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);