import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^\\s\\n])\\d{3}[./]\\d{3,6}(?:/\\d{3})?(?![^\\s\\n])";
final String string = "Codes like 123/456\n"
+ " \n"
+ "123/3456 \n"
+ "123/23456\n"
+ " etc are correct\n\n"
+ "lorem\\123/456 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}