# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/$//gm;t' <<< "http://www.domain.com/clients/
http://www.domain.com/clients"