const regex = /\/$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/$', 'gm')
const str = `http://www.domain.com/clients/
http://www.domain.com/clients`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);