$re = '/\/$/m';
$str = 'http://www.domain.com/clients/
http://www.domain.com/clients';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;