use strict;
my $str = 'http://www.domain.com/clients/
http://www.domain.com/clients';
my $regex = qr/\/$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";