#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mix)^(.*?)(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?$"
Local $sString = "1.jpg" & @CRLF & _
"2.jpg" & @CRLF & _
"3.jpg" & @CRLF & _
"4.jpg" & @CRLF & _
"5.jpg" & @CRLF & _
"6.jpg" & @CRLF & _
"7.jpg" & @CRLF & _
"8.jpg" & @CRLF & _
"9.jpg" & @CRLF & _
"10.jpg" & @CRLF & _
"11.jpg" & @CRLF & _
"12.jpg" & @CRLF & _
"13.jpg" & @CRLF & _
"14.jpg" & @CRLF & _
"15.jpg" & @CRLF & _
"16.jpg" & @CRLF & _
"17.jpg" & @CRLF & _
"18.jpg" & @CRLF & _
"19.jpg" & @CRLF & _
"20.jpg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")