import re
regex = re.compile(r"""
^(.*?)(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?$
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("1.jpg\n"
"2.jpg\n"
"3.jpg\n"
"4.jpg\n"
"5.jpg\n"
"6.jpg\n"
"7.jpg\n"
"8.jpg\n"
"9.jpg\n"
"10.jpg\n"
"11.jpg\n"
"12.jpg\n"
"13.jpg\n"
"14.jpg\n"
"15.jpg\n"
"16.jpg\n"
"17.jpg\n"
"18.jpg\n"
"19.jpg\n"
"20.jpg\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")