use strict;
my $str = '1.jpg
2.jpg
3.jpg
4.jpg
5.jpg
6.jpg
7.jpg
8.jpg
9.jpg
10.jpg
11.jpg
12.jpg
13.jpg
14.jpg
15.jpg
16.jpg
17.jpg
18.jpg
19.jpg
20.jpg
';
my $regex = qr/^(.*?)(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?$/mixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}