import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?(?:\\n(.+?))?$";
final String string = "1.jpg\n"
+ "2.jpg\n"
+ "3.jpg\n"
+ "4.jpg\n"
+ "5.jpg\n"
+ "6.jpg\n"
+ "7.jpg\n"
+ "8.jpg\n"
+ "9.jpg\n"
+ "10.jpg\n"
+ "11.jpg\n"
+ "12.jpg\n"
+ "13.jpg\n"
+ "14.jpg\n"
+ "15.jpg\n"
+ "16.jpg\n"
+ "17.jpg\n"
+ "18.jpg\n"
+ "19.jpg\n"
+ "20.jpg\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}