import Foundation
let pattern = #"^(.*?)(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?(?:\n(.+?))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
1.jpg
2.jpg
3.jpg
4.jpg
5.jpg
6.jpg
7.jpg
8.jpg
9.jpg
10.jpg
11.jpg
12.jpg
13.jpg
14.jpg
15.jpg
16.jpg
17.jpg
18.jpg
19.jpg
20.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)