import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+Client\\sName:\\s(?<name>.+)\\s+:\\s+Client\\sEmail:\\s(?<email>.+)\\s+:\\s+Product\\sName";
final String string = "Test School BV Client Name: test : Client Email: test@gmail.com : Product Name: test : Billing Cycle: 12 : Country: CO : Domain: test.com.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}