using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a [^>]+?)>\s+<img src=""[^""]+?"" alt=""([^""]+)""";
string input = @"<a href=""/1.webp"" data-fancybox=""gallary"">
<img src=""/1.webp"" alt=""$img_alt"">
</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}