re = /(<a [^>]+?)>\s+<img src="[^"]+?" alt="([^"]+)"/m
str = '<a href="/1.webp" data-fancybox="gallary">
<img src="/1.webp" alt="$img_alt">
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end