package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a [^>]+?)>\s+<img src="[^"]+?" alt="([^"]+)"`)
var str = `<a href="/1.webp" data-fancybox="gallary">
<img src="/1.webp" alt="$img_alt">
</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}