import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a [^>]+?)>\\s+<img src=\"[^\"]+?\" alt=\"([^\"]+)\"";
final String string = "<a href=\"/1.webp\" data-fancybox=\"gallary\">\n"
+ " <img src=\"/1.webp\" alt=\"$img_alt\">\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}