using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"series.*?([0-9]+).*?image.*?([0-9]+)";
string input = @"""(series 602 image 91)"" or "" series number 89 and image number 34"" or ""Series # 4, Image # 14""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}