const regex = /series.*?([0-9]+).*?image.*?([0-9]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('series.*?([0-9]+).*?image.*?([0-9]+)', 'gmi')
const str = `"(series 602 image 91)" or " series number 89 and image number 34" or "Series # 4, Image # 14"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}