re = /series.*?([0-9]+).*?image.*?([0-9]+)/mi
str = '"(series 602 image 91)" or " series number 89 and image number 34" or "Series # 4, Image # 14"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end