$re = '/series.*?([0-9]+).*?image.*?([0-9]+)/mi';
$str = '"(series 602 image 91)" or " series number 89 and image number 34" or "Series # 4, Image # 14"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);