// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)series.*?([0-9]+).*?image.*?([0-9]+)").unwrap();
let string = "\"(series 602 image 91)\" or \" series number 89 and image number 34\" or \"Series # 4, Image # 14\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}