using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#([0-9A-F]{3}){1,2}$";
string input = @"Only matches when there are 3 & 6 digits
#
#1
#12
#123
#1234
#12345
#123456
#1234567
Only matches if the letters used are: A, B, C, D, E & F
#ABCDEF
#BCDEFG
#0A1B2C
#0E1F2Z
Must use the 'i' flag to match lower & upper case.
#AaBbCc";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}