const regex = /^#([0-9A-F]{3}){1,2}$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#([0-9A-F]{3}){1,2}$', 'igm')
const str = `Only matches when there are 3 & 6 digits
#
#1
#12
#123
#1234
#12345
#123456
#1234567
Only matches if the letters used are: A, B, C, D, E & F
#ABCDEF
#BCDEFG
#0A1B2C
#0E1F2Z
Must use the 'i' flag to match lower & upper case.
#AaBbCc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}