$re = '/^#([0-9A-F]{3}){1,2}$/im';
$str = 'Only matches when there are 3 & 6 digits
#
#1
#12
#123
#1234
#12345
#123456
#1234567
Only matches if the letters used are: A, B, C, D, E & F
#ABCDEF
#BCDEFG
#0A1B2C
#0E1F2Z
Must use the \'i\' flag to match lower & upper case.
#AaBbCc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);