# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[01]?\d|2[0-3]):([0-5]?\d:[0-5]?\d):\d+$/$1/gm;t' <<< "00:06:29:14"