use strict;
my $str = '00:06:29:14';
my $regex = qr/^(?:[01]?\d|2[0-3]):([0-5]?\d:[0-5]?\d):\d+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";