$re = '/^(?:[01]?\d|2[0-3]):([0-5]?\d:[0-5]?\d):\d+$/m';
$str = '00:06:29:14';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;