const regex = /^(?:[01]?\d|2[0-3]):([0-5]?\d:[0-5]?\d):\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[01]?\\d|2[0-3]):([0-5]?\\d:[0-5]?\\d):\\d+$', 'gm')
const str = `00:06:29:14`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);