import re
regex = re.compile(r"^(?:[01]?\d|2[0-3]):([0-5]?\d:[0-5]?\d):\d+$", flags=re.MULTILINE)
test_str = "00:06:29:14"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)