using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(code|php)\]([\s\S]+?)\[\/\1\]";
string input = @"[code]here is some code[/code]
[php]here is some other code[/php]
[code]this is malformed[/php]
[php]and so is this[/code]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}