import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(code|php)\\]([\\s\\S]+?)\\[\\/\\1\\]";
final String string = "[code]here is some code[/code]\n"
+ "[php]here is some other code[/php]\n"
+ "[code]this is malformed[/php]\n"
+ "[php]and so is this[/code]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}