re = /\[(code|php)\]([\s\S]+?)\[\/\1\]/m
str = '[code]here is some code[/code]
[php]here is some other code[/php]
[code]this is malformed[/php]
[php]and so is this[/code]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end