const regex = /\[(code|php)\]([\s\S]+?)\[\/\1\]/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(code|php)\\]([\\s\\S]+?)\\[\\\/\\1\\]', 'mg')
const str = `[code]here is some code[/code]
[php]here is some other code[/php]
[code]this is malformed[/php]
[php]and so is this[/code]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}