// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\Дней.*\:).*)").unwrap();
let string = "Битва экстрасенсов 17 сезон Дней д о следующей серии: 2
/[^a-zA-Za-åa-ö-w-я 0-9/@%!\"#?¨'_.,]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}