import Foundation
let pattern = #"((\Дней.*\:).*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Битва экстрасенсов 17 сезон Дней до следующей серии: 2
/[^a-zA-Za-åa-ö-w-я 0-9/@%!"#?¨'_.,]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}