#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\d{2,4}\/){2}\d\d\d\d.*\n\s+Logs are not written"
Local $sString = "12/20/2015 03:13:45 THis is text" & @CRLF & _
" Logs are not written" & @CRLF & _
"12/30/2015 04:13:45 THis is more text" & @CRLF & _
" Stuff happens" & @CRLF & _
"12/20/2015 03:13:45 THis is text" & @CRLF & _
" Logs are not written" & @CRLF & _
"Test THis" & @CRLF & _
"12/20/2015 03:13:45 THis is text" & @CRLF & _
" Logs are not written" & @CRLF & _
"Test THat on two lines" & @CRLF & _
" THis is the second line" & @CRLF & _
"12/20/2015 03:13:45 THis is text" & @CRLF & _
" Logs are not written"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")