re = /(\d{2,4}\/){2}\d\d\d\d.*\n\s+Logs are not written/i
str = '12/20/2015 03:13:45 THis is text
Logs are not written
12/30/2015 04:13:45 THis is more text
Stuff happens
12/20/2015 03:13:45 THis is text
Logs are not written
Test THis
12/20/2015 03:13:45 THis is text
Logs are not written
Test THat on two lines
THis is the second line
12/20/2015 03:13:45 THis is text
Logs are not written'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end